Errore aggiornamento Wordpress 4.4


Utenti Wordpress, aspettate ad aggiornare alal versione 4.4 .

C'è una segnalazione diffusa di un errore a seguito dell'aggiornamento che inibisce l'accesso alla bacheca. Il sito continua a funzionare regolarmente per i visitatori, ma l'amministratore non può più accedere a wp-admin .

Il problema non si manifesta in tutti i blog aggiornati alla nuova versione, ma sono colpiti una buona percentuale, anche se ancora non è stata individuata la discriminante per cui l'aggiornamento su un sito funziona bene e crea l'errore su un altro sito .

Errore di aggiornamento wordpress 4.4

Nello specifico l'errore che si presenta all'admin dopo l'aggiornamento è il seguente:

 Call to undefined function wp_removable_query_args() in /www.TUOSITO.it/htdocs/wp-admin/includes/misc.php on line 900

Come detto il sito alle visite risponde regolarmente, il problema è solo in amministrazione .

Come risolvere l'errore di aggiornamento wordpress 4.4

Tra le tante soluzioni trovate in rete molte non funzionano o portano ad ulteriori errori, comunque tutti legati alle chiamate del file functions.php .

La soluzione più gettonata è quella di scaricare i file dell' ultima versione di WP dal sito ufficiale e copiare le cartelle wp-admin e wp-includes nel proprio spazio web. Praticamente si sovrascrive l'intero motore di WordPress . Attenzione a salvare eventuali personalizzazioni fatte direttamente sui file .

La mia soluzione è più semplice, anche se meno ortodossa .

Ho prelevato il file /wp-includes/functions.php dalla versione 4.3.1  e l'ho sostituito a quello modificato dalla versione 4.4 .

Con il vecchio file funtions.php tutto funziona regolarmente e non ho errori ne nella parte amministrativa ne in quella a disposizione degli utenti visitatori.

 





Articolo tratto da: Palinsesto - non c'è più la tv - http://palinsesto.altervista.org/
URL di riferimento: http://palinsesto.altervista.org/index.php?mod=read&id=1450003113